討人厭的CheckImcompatible

在執行RobotTesting中的OpenBrowser,去開啟待測的URL時,你是否會出現如下圖的Dialog呢?

原因是開發機fireofx升級為15後,有些plugin不相容而導致的。因為一直跳出這個Dialog很煩,所以我透過修改prefs.js解決這個問題。
(不曉得prefs.js是什麼可以參考: link)
新增extensions.checkCompatibility屬性,後面為版本號,看你的firefox版本是什麼就填寫什麼。

user_pref("extensions.checkCompatibility.15.0", false);


還有在13.0.1版本的firefox上,即使加了extensions.checkCompatibility,一樣會做相容性檢查。最後是將底下這行註解就解決了。

//user_pref("extensions.lastAppVersion", "3.6.12");